interface LoggerInterface implements LoggerInterface

deprecated since version 2.2, to be removed in 3.0. Type-hint \Psr\Log\LoggerInterface instead.

LoggerInterface.

Methods

emerg($message, array $context = array()) deprecated

No description

crit($message, array $context = array()) deprecated

No description

err($message, array $context = array()) deprecated

No description

warn($message, array $context = array()) deprecated

No description

Details

at line line 28
emerg($message, array $context = array()) deprecated

deprecated since version 2.2, to be removed in 3.0. Use emergency() which is PSR-3 compatible.

Parameters

$message
array $context

at line line 33
crit($message, array $context = array()) deprecated

deprecated since version 2.2, to be removed in 3.0. Use critical() which is PSR-3 compatible.

Parameters

$message
array $context

at line line 38
err($message, array $context = array()) deprecated

deprecated since version 2.2, to be removed in 3.0. Use error() which is PSR-3 compatible.

Parameters

$message
array $context

at line line 43
warn($message, array $context = array()) deprecated

deprecated since version 2.2, to be removed in 3.0. Use warning() which is PSR-3 compatible.

Parameters

$message
array $context